+1 голос

Подскажите, что делать, если при обновлении Windows у меня ошбика: 

api-ms-win-core-libraryloader-l1-1-1.dl

спросил (250 баллов) в категории Софт

1 Ответ

0 гол..

Довольно часто пользователи встречаются с проблемой «api-ms-win-core-libraryloader-l1-1-1.dll» при апгрейде Виндовс с 7 до 10 при помощи встроенного помощника для обновлений операционной системы. Это ошибка стала встречаться относительно недавно, но многие так и не понимают в чем она заключается.


Суть этой проблемы кроется в следующем:

Обновления Виндовс не устанавливаются по той причине, что файл «api-ms-win-core-libraryloader-l1-1-1.dll» либо не существует, либо с ним что-то не так.

Устранение ошибки api-ms-win-core-libraryloader-l1-1-1.dll

Но несмотря на странность этой проблемы ее решение достаточно простое. Так как ошибка возникает уже во время обновления операционной системы то все нужные для этого файлы уже установлены на компьютер. Чтобы искоренить ошибку необходимо следовать инструкции по ее устранению:

  • Зайти в папку с путем C:\Windows\System32\ и скопировать оттуда файл с названием «wimgapi.dll»;
  • После чего скопированный файл необходимо вставить в папку с путем C:\Windows10Upgrade\;
  • В этой папке уже есть файл с таким названием поэтому необходимо подтвердить замену старого файла на новый.

Чтобы проверить, что ошибка устранена необходимо заново обновить операционную систему до Виндовс 10.

Если установка прошла успешна, то проблема устранена. Если же она вновь возникает, значит необходимо повторить вышеописанные действия.

ответ (2.8k баллов)
15,323 вопросов
15,878 ответов
262 комментариев
1,058 пользователей